Search found 8 matches

Go to advanced search

by rwschumann
Tue Jun 26, 2018 12:56 pm
Forum: General Discussion
Topic: Voltage Clamp behaviour
Replies: 3
Views: 1154

Re: Voltage Clamp behaviour

Excellent thank you for the helpful suggestions.
by rwschumann
Sun Jun 24, 2018 1:14 pm
Forum: General Discussion
Topic: Voltage Clamp behaviour
Replies: 3
Views: 1154

Re: Voltage Clamp behaviour

Never Mind I figured it out. Was not an issue with the voltage clamp circuit at all, was an issue with too high of a momentary load on the switching power supply. I slowed down the acceleration and problem went away. As acceleration was slowed it was easy to watch the dips in the source voltage mini...
by rwschumann
Fri Jun 22, 2018 6:38 pm
Forum: General Discussion
Topic: Voltage Clamp behaviour
Replies: 3
Views: 1154

Voltage Clamp behaviour

Hi, I am using a switched mode power supply (24V supply @ 3.5 amps) to drive a small 24V motor (peak load observed is around 1.2 amps). Per the documentation I have put in a voltage clamp circuit, but I was still controller errors (appearing as Low logic voltage, but in fact power also goes down to ...
by rwschumann
Fri Jun 22, 2018 1:07 pm
Forum: Velocity and Position Control
Topic: Negative position?
Replies: 5
Views: 1494

Re: Negative position?

I have included two files, below 1) Arduino code which executes 'forward' and 'backward' distance and position commands 2) Log file showing results of the calls. In the log file you can see that: a) When doing a forward call (either distance or position) it all works fine. b) When doing a position b...
by rwschumann
Thu Jun 21, 2018 1:24 pm
Forum: Velocity and Position Control
Topic: Negative position?
Replies: 5
Views: 1494

Re: Negative position?

Correct. When I read the position I am able to accurately see it go negative. However if I use a position command, such as 66 - Buffered Drive M2 with signed Speed, Accel, Deccel and Position Move M2 position from the current position to the specified new position and hold the new position. Accel se...
by rwschumann
Thu Jun 21, 2018 1:20 pm
Forum: General Discussion
Topic: Serial command to set undocumented S3, S4, S5 modes
Replies: 7
Views: 3385

Re: Serial command to set undocumented S3, S4, S5 modes

The current manual also needs to be updated as it shows a mode of 3 for going into voltage clamp mode. Sending this actually causes it to go into an estop latch and it halts with an estop error if an actual voltage clamp circuit is attached. I am running firmware 4.1.24 Manual has no visible ID or m...
by rwschumann
Wed Jun 20, 2018 8:21 am
Forum: Velocity and Position Control
Topic: Is encoder count signed or unsigned?
Replies: 3
Views: 1157

Re: Is encoder count signed or unsigned?

Note this issue also exists as it relates to the position based commands.

If the encoder is really a signed value, which I would suggest is the correct approach, then it needs to be used consistently including with position.

thanks,
Rob
by rwschumann
Wed Jun 20, 2018 8:20 am
Forum: Velocity and Position Control
Topic: Negative position?
Replies: 5
Views: 1494

Negative position?

I want to use the position commands to control how much movement occurs. I was planning on using the zero encoder position as my mid point (eg moving backwards would result in a negative encoder count). When using distance commands and such the encoder behaves as I would expect going positive and ne...

Go to advanced search

cron