Windows 10 - RoboClaw not recognised

General discussion of using Roboclaw motor controllers
konstantinos
Posts: 2
Joined: Fri Jun 22, 2018 1:34 am

Windows 10 - RoboClaw not recognised

Postby konstantinos » Fri Jun 22, 2018 4:24 am

Hi to all,

I have recently purchased 2xRoboclaw 2x30A V5E and tried to connect them to a Windows 10 laptop (USB3). I followed the following steps...

1st attempt:
Plug in a common power supply (12V, 1A) in RoboClaws battery pins and afterwards connect the Roboclaw to the laptop via usb -> windows 10 and Ion Studio did not recognized roboclaw existance.

2nd attempt:
Plug in a battery pack 2200mAh 11.1V, 25C in RoboClaw's battery pins and afterwards connect the Roboclaw to the laptop via usb -> windows 10 and Ion Studio did not recognized roboclaw existance.

The really interesting thing is that the LEDs are blinking correctly and I did some basic button configuration with the mode, set and lipo buttons but the connection to the laptop seems to be problematic.. Also, roboclaw's usb port seems not to be damaged as if I take out the main power supply and connect the board to the laptop the on board LEDs blink (not strongly but...blink).

So my question is if I can try something different in order to get the roboclaw working together with a PC...

P.S 1: Today I will try connect the roboclaw with serial connection to an arduino board hoping to get in touch with it :)

P.S 2: I did tried all the above procedures to all 2 roboclaws that I did buy...but their "behaviour was the same.

Any Ideas? :)
Thanks in advance.

User avatar
Basicmicro Support
Posts: 1015
Joined: Thu Feb 26, 2015 9:45 pm

Re: Windows 10 - RoboClaw not recognised

Postby Basicmicro Support » Fri Jun 22, 2018 10:02 am

I dont see anything in your post saying you installed the USB driver when you tested. You need to install the Windows USB driver for Roboclaw before Win 10 will see the board. It is available in the download section of the website.

Everything else(powering the board seperately and connections) look correct.

konstantinos
Posts: 2
Joined: Fri Jun 22, 2018 1:34 am

Re: Windows 10 - RoboClaw not recognised

Postby konstantinos » Sat Jun 23, 2018 12:40 am

Yes, i forgot to say that..

I installed the x64 driver for windows before everything..Also I tried the same in windows 7 laptop with usb2.0 port..but still the same..

User avatar
Basicmicro Support
Posts: 1015
Joined: Thu Feb 26, 2015 9:45 pm

Re: Windows 10 - RoboClaw not recognised

Postby Basicmicro Support » Tue Jun 26, 2018 8:40 am

Did you try a different USB cable. The odds of two Roboclaws having bad USB ports it basically zero. The test we run before they are packaged is run from the USB connection.

Are you using a direct USB port on a PC or a USB hub? If you are using a HUB test with a direct port. Test with a different USB port and different USB cable as well.

Open Device Manager and see if the Roboclaw shows up(it will show up as a Virtual comport in the Ports section.


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests

cron